Back to Vulnerability Directory
CRITICALFixed upstream

CVE-2024-45216

Improper Authentication vulnerability in Apache Solr.

Technology

Apache Solr

CVSS Score

9.8 / 10.0

Affected Versions

>=5.3.0 <8.11.4; >=9.0.0 <9.7.0

Upstream Fix

See upstream advisory

Published

October 16, 2024

OSSeva Coverage

Fixed upstream

Description

Improper Authentication vulnerability in Apache Solr. Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing. This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0. Users are recommended to upgrade to version 9.7.0, or 8.11.4, which

Upstream record: NVD · CVE.org

Is your Apache Solr deployment affected?

If you're running >=5.3.0 <8.11.4; >=9.0.0 <9.7.0, you need this patch. Book a discovery call to get covered.

Get a quote

Running Apache Solr >=5.3.0 <8.11.4; >=9.0.0 <9.7.0?

Send your work email and a senior engineer will tell you whether this CVE applies to your versions and who patches it. Reply within 1 business day.

Only your email is required · An engineer replies within 1 business day · No commitment

Prefer to talk or read more first?

Book a call